Windows Server 2016, como impactan los niveles funcionales de nuestro Active Directory en nuestro Exchange 2016

www.radians.com.ar Ya hemos hablado varias veces de los niveles funcionales de Active Directory en las distintas versiones de Windows Server, ya sea 2008, 2012, 2012r2 y ahora finalmente 2016. En este caso veremos el impacto sobre nuestro Exchange Server 2016. Es algo a tener en cuenta si estamos pensando en implementar tanto Windows Server 2016 o Exchange Server 2016, o ambos.

En septiembre de este año 2016 se ha publicado una declaración que está causando cierta confusión entre los clientes. La confusión se relaciona con el soporte de Windows Server 2016 con Exchange Server 2016. En el blog se decía: "Los controladores de dominio que ejecutan Windows Server 2016 son compatibles, siempre que el nivel funcional del bosque sea Windows Server 2008R2 o posterior". Por lo cual se debe tener en cuenta varias cosas y entender que es lo que significa esta declaración, que funciona y que no.

  • Preguntaa #1: Si quiero implementar Exchange Server 2016, ¿mi entorno de Active Directory debe usar Forest Functional Level 2008R2 o posterior?
    Respuesta #1: No. Exchange Server 2016 está soportado en entornos configurados para Forest Functional Level 2008 y posteriores.
  • Preguntaa #2: ¿Si quiero instalar Exchange Server en un servidor que ejecuta Windows Server 2016, mi entorno de Active Directory necesita estar en el nivel funcional del bosque a 2008R2 o posterior?
    Respuesta #2: No. Se puede tener la instalación de Exchange Server 2016 en Windows Server 2016 si Active Directory está configurado en Forest Functional Level 2008 y posteriores.
  • Preguntaa #3: ¿Cuál es el requisito real que necesitamos en cuento al nivel funcional de nuestro Active Directory?
    Respuesta #3: Si estamos ejecutando Exchange 2016 en cualquier parte de nuestro entorno y si alguno de los controladores de dominio que utiliza Exchange ejecuta Windows Server 2016, el nivel funcional del bosque debe elevarse a 2008R2 o posterior. Según Microsoft, los clientes que mantienen sus controladores de dominio implementados la versión más reciente del SO, también emplean el más alto nivel de confiabilidad, seguridad y funcionalidad y este requisito no debería ser un bloqueador de implementación.
  • Preguntaa #4: ¿Por qué se requiere el Nivel Funcional Forestal 2008R2 o posterior?
    Respuesta #4: Implementar un nivel más alto de funcionalidad en nuestro Active Directory requiere que los DCs que tengan sistemas operativos antiguos sean retirados. Nuestro objetivo es asegurarnos de que Exchange Server utilice el nivel más alto en referencia a las configuraciones de seguridad, incluyendo los estándares criptográficos más recientes. Windows Server 2008 ya no cumple con el estándar mínimo que estamos requiriendo y que es solicitado por los clientes. Los clientes que están implementando la última versión de Exchange y Windows Server a menudo lo hacen para mejorar la seguridad de su ecosistema general. Nuestro objetivo es asegurarse de que Exchange Server funciona correctamente bajo estas suposiciones y requisitos. Limitar el uso de estándares antiguos permite que Exchange Server cumpla con los requisitos de los estándares de seguridad actuales.
  • Preguntaa #5: ¿Exchange Setup bloqueará la instalación de Exchange Server 2016 si utilizo Windows Server 2016 en un controlador de dominio pero no he aumentado el nivel funcional de bosque?
    Respuesta #5: En este momento, no hay ningún bloque de instalación. Este requisito previo es un requisito “suave” impuesto por una política solamente. Si un cliente llama al soporte y está utilizando los controladores de dominio de Windows Server 2016 con Exchange Server 2016 y no ha aumentado el nivel funcional del bosque al valor mínimo, Microsoft puede pedirnos que lo hagamos como parte de la eliminación de causas raíz ante cualquier inconveniente que tengamos.
  • Preguntaa #6: ¿Cuándo el programa de instalación de Exchange forzará el uso de 2008R2 Forest Functional Level para una instalación de Exchange Server?
    Respuesta #6: El Nivel Funcional del Forest mínimo soportado se elevará a 2008R2 en el Cumulative Update 7 para todas las implementaciones de Exchange Server 2016. Sabemos que los clientes necesitan tiempo para planificar e implementar la migración/desactivación necesaria de los servidores Active Directory. El nivel funcional del bosque 2008R2 será un requisito “duro” en la Cumulative Update 7, impuesta por el programa de instalación de Exchange. Cumulative Update 7 estara disponible en el 3er trimestre de 2017, un año después del primer anuncio.

Para obtener una lista completa de los requisitos de cambio les recomiendo revisar la nota de TechNet.microsoft.com

Espero que les sea de interés. saludos. Roberto Di Lello

Roberto Di Lello

Acerca del autor: Roberto Di Lello

Hola, soy Roberto Di Lello trabajo como Consultor Senior en Infraestructura, especializado en Tecnologias Microsoft con mas de 25 años en la industria. He sido galardonado como MS-MVP en Active Directory-Enterprise Mobility por 10 años, y actualmente soy MVP Windows Insider, ademas de poseer otras certificaciones de Microsoft. He trabajado en distintos projectos que involucran Migraciones, Implementaciones, y soporte de Active Directory y Microsoft Exchange, y en los ultimos años me he desempeñado armando equipos de trabajo para diferentes paises y areas de sistemas, he planificado a distintas migraciones a datacenters (ambiente cloud y mixtos). He tenido la oportunidad de participar como miembro del staff de Microsoft en eventos internacionales como ser TechEd NorteAmerica y MS Ignite (NA) al ser Trainer Certificado por Microsoft (MCT).

You May Also Like

1 Comment

  1. Нeⅼlo there! I could have sworn I’ve visited tһis blog before but after looking at a few
    of the articles I realized it’s new to me. Nonethelеss, I’m certainly happy I came across it and I’ll be bookmarking it and checking back frequently!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.