Home
About
Archives
Contactenos
Ayuda | Help

26  10 2011

Como eliminar un adaptador de red oculto (Hidden Network Adapter: Microsoft Virtual Machine Bus Network Adapter #2) de una Maquina Virtual (VM) en Hyper-V o VirtualPC {HowTo}

Hoy vamos a ver como solucionar un problema frecuente cuando estamos trabajando con varias maquinas virtuales (VMs) que por alguna razón copiamos nuevamente y debemos asignarle la misma dirección IP que tenia previamente.

Cuando nos ocurre esto, nos aparece el siguiente mensaje:

www.radians.com.ar © 2011

El problema de esto es que si hacemos caso omiso a esta advertencia, nuestra VM no nos tomara la IP; entonces tenemos dos opciones:

  • Cambiamos la IP, cosa que no siempre se puede, como en nuestro caso.
  • Ejecutamos este tutorial Risa

Aquí vemos que no nos toma la IP.

www.radians.com.ar © 2011

Si vamos a la consola de administración de dispositivos, vemos lo siguiente:

www.radians.com.ar © 2011

Podemos observar que no tenemos las redes 0 y 1, pero si tenemos la Microsoft Virtual Machine Bus Network Adapter #3 y Microsoft Virtual Machine Bus Network Adapter #4.

Para poder corregir este error, abrimos la consola de línea de comando cmd, y ejecutamos lo siguiente set devmgr_show_nonpresent_devices=1. Luego ejecutamos nuevamente la consola de administración de dispositivos, lo podemos hacer desde la misma ventana de línea de comando de la siguiente forma: start devmgmt.msc.

www.radians.com.ar © 2011

Una vez que la consola esta disponible, seleccionamos View, y luego Show hidden devices.

www.radians.com.ar © 2011

Una vez que hicimos este cambio, en la sección Network Adapters, podemos ver la lista de dispositivos que tiene la VM:

  • Microsoft Virtual Machine Bus Network Adapter
  • Microsoft Virtual Machine Bus Network Adapter #2
  • Microsoft Virtual Machine Bus Network Adapter #3
  • Microsoft Virtual Machine Bus Network Adapter #4

www.radians.com.ar © 2011

Entonces, seleccionamos cada uno de los dispositivos y los desinstalamos, haciendo un clic con el botón derecho y seleccionando Uninstall.

www.radians.com.ar © 2011

Aceptamos la desinstalación del dispositivo. Este proceso tarda unos minutos; repetimos este procedimiento para cada uno de los dispositivos de red.

www.radians.com.ar © 2011

www.radians.com.ar © 2011

Cuando eliminamos todos los adaptadores de red, hacemos un clic con el botón derecho sobre Newtwork Adapters, y seleccionamos Scan for hardware changes.

www.radians.com.ar © 2011

Después de este procedimiento podremos ver los adaptadores de red originales. Igualmente es recomendable reiniciar el equipo.

www.radians.com.ar © 2011

Después de hacer esto, podremos configurar la dirección IP que deseábamos correctamente. Espero que les sea de utilidad. Saludos, Roberto Di Lello.

En 2014 debido a nuevas disposiciones de la ley Argentina debo afrontar distintos gastos para mantener el blog en funcionamiento. Si te parecio util la informacion del blog hace click en el boton "DONATE" o Ayudar al Blog - DONAR Si te ha gustado este post, por favor considera Dejar un Comentario o Suscribirse a este sitio por medio de RSS para tener los futuros artículos desarrollados en su lector de feeds.

10 Comentarios to “Como eliminar un adaptador de red oculto (Hidden Network Adapter: Microsoft Virtual Machine Bus Network Adapter #2) de una Maquina Virtual (VM) en Hyper-V o VirtualPC {HowTo}”

  1. Hola Roberto:

    Podrias ayudarme, tengo un problema al crear un Active Directory secundario…

    He agregado el rol de Active directory, luego DCPROMO, configuracion avanzada, opcion de replicacion (NO RODC), despues del resumen del asistente, procesa y me da el siguiente error:

    Asistente para la instalación de los Servicios de dominio de Active Directory
    —————————
    Se produjo el siguiente error en la operación:
    Se está ejecutando la operación de E/S superpuesta.

    Tengo Windows 2008 R2, el nivel funcional es el mismo.
    En este servidor tiene los roles: Servicios de Archivos, Servidor Web IIS, Windows Server Update Services.

    Mi DC principal, tiene el rol: DNS.

    Muchas gracias de antemano.

    Saludos,Henry M.C.

  2. Hola Henry, descarta mi mail anterior que se envió por error mientras estaba armando la respuesta correcta a tu consulta. En principio, disculpa mi demora pero estuve muy complicado con los tiempos y con el evento de Virtualización del viernes próximo. Se me juntaron muchos mails para responder

    La causa de tu error podrían ser varias, pero verifica tambien que no tengas ningun antivirus ejecutandose en background. Mira la siguiente nota al respecto: Error: Operación de E/s superpuesto está en curso http://support.microsoft.com/kb/295712

    Pudiste mirar el log a ver si hay mas información? hay algún evento asociado en el event viewer?

    Muchas gracias por participar del blog y ayudar a que siga creciendo! Te cuento que hay mucho material en el.
    Te invito a que veas los labs, videos, tutoriales, notas. Si querés buscar un tema o necesitas ayuda, tenés la solapa AYUDA donde explico un poco como hacerlo, sino también tenés el buscador de google.
    Espero te sean de utilidad. Saludos!

  3. Podrias ayudarme, tengo un problema al crear un Active Directory secundario…

    He agregado el rol de Active directory, luego DCPROMO, configuracion avanzada, opcion de replicacion (NO RODC), despues del resumen del asistente, procesa y me da el siguiente error:

    Asistente para la instalación de los Servicios de dominio de Active Directory
    —————————
    Se produjo el siguiente error en la operación:
    Se está ejecutando la operación de E/S superpuesta.

    Tengo Windows 2008 R2, el nivel funcional es el mismo.
    En este servidor (ad secundario) tiene los roles: Servicios de Archivos, Servidor Web IIS, Windows Server Update Services.
    Mi DC principal, tiene los roles: Servicios de archivos, Servicio de Dominio de Active Directory y Servidor DNS.
    Muchas gracias de antemano.

  4. Hola Henry, te envió otros mails respondiéndote.

    Lo que veo ahora, es que tenés dos DCs? y como están distribuidos los FSMO???
    Saludos!

  5. Roberto Di buen dia, le agradesco de antemano si es posible me ayude con un problema, tengo 10 computadoras en un dominio y dos impresoras laser instaladas en dos computadoras, pero todos los dias y a cada rato debo desinstalarlas y volver a instalar para que funcionen correctamente, imprimen unas apginas y luego se queda en colo los trabajos, a veces detengo el servicio “cola de impresion” vuelvo y lo subo en 20 seg imprime normalmente.
    gracias por sus recomendaciones

  6. Hola Orlando, disculpa mi demora pero estuve muy complicado con los tiempos y con el evento de Virtualización del viernes próximo. Se me juntaron muchos mails para responder

    Es raro lo que te esta pasando. En principio esta todo el resto de las cosas funcionando bien?, tu dominio funciona correctamente y tus DNS también, no?. Las impresoras están conectadas por IP?, tenés un servidor de impresión configurado? Los drivers, son los drivers firmados y soportados por tu versión de Windows? Como están configuradas las impresoras en los clientes?Pudiste mirar el log a ver si hay mas información? hay algún evento asociado en el event viewer?

    Disculpa toda esta serie de preguntas, pero me ayudaran a entender mejor tu arquitectura. Muchas gracias por participar del blog y ayudar a que siga creciendo! Te cuento que hay mucho material en el.
    Te invito a que veas los labs, videos, tutoriales, notas. Si querés buscar un tema o necesitas ayuda, tenés la solapa AYUDA donde explico un poco como hacerlo, sino también tenés el buscador de google.
    Espero te sean de utilidad. Saludos!

  7. Hola Roberto: Gracias por tu tiempo.

    Recien he creado 1 DC principal en un nuevo bosque. Intente crear un DC secundario de contigencia, pero salio el error indicado, revisare si el SCE tiene algun servicio de “copia de seguridad”, sino tendre que desinstalarlo o hacerlo en otro servidor W208R2 o en algun virtual.

    Te comentare sobre los resultados de la revision, una vez mas muchas gracias.

    Una consulta sobre el tema de virtualizacion que estas preparando para el viernes, es un webcast online??? o algo parecido.

    Gracias,Henry M.C.

  8. Hola Henry, disculpa la demora, realmente no se si te llego. La charla era presencial en EXO, pero ya estaba el cupo completo.
    Podes ver parte de la presentación en mi blog.

    Pudiste con tu tema con los dos DCs? y como están distribuidos los FSMO???

    Saludos.

  9. Buenas dias, tengo el problema de adaptadores fantasmas, realice todos los pasos pero cuando reinicio vuelve aparecer la red #2. Necesito urgente tu ayuda

  10. Hilary, disculpa mi demora en contestar pero estuve con algunos temas de salud, y estoy medio complicado con los tiempos y voy respondiendo de a poco a medida que puedo.

    Respecto a tu pregunta, este seria el procedimiento mas facil, igualmente te pao dos links que te pueden ayudar y que describen tu problema:
    * Aparece un mensaje de error al intentar establecer una dirección IP en un adaptador de red http://support.microsoft.com/kb/269155
    * Remove Non-Existing Network Adapters 2003 & 2008 Servers http://www.activeservers.com/Remove-Non-Existing-Network-Adapters.aspx

    Aprovecho la oportunidad para agradecerte por participar del blog y ayudar a que siga creciendo! Te pido que difundas la direccion del sitio y mi twitter @RaDiansBlog, asi sumamos mas gente. Te cuento que hay mucho material en el. Te invito a que veas los labs, videos, tutoriales, notas. Si querés buscar un tema o necesitas ayuda, tenés la solapa AYUDA donde explico un poco como hacerlo, sino también tenés el buscador de google.

    Saludos y gracias!

« »